OSPF & BGP with Cisco IOS

bsd/ospf | bsd/ospf-n-bgp | bsd/bgp | cisco/ospf | cisco/ospf-n-bgp | cisco/bgp

assuming gns3 c3725 dynamips appliances

IMAGE HERE

We’re starting-off with the multi-area ospf setup — break the OSPF AREA 0 and replace it with BGP instead.

Note R1 still has a default route thanks to DHCP but we’re not willing to advertise it through BGP.

R1 and its default route — nothing to change here

interface FastEthernet0/0
    ip address dhcp
    ip ospf 1 area 1

interface FastEthernet0/1
    ip address 10.1.1.254 255.255.255.0
    ip ospf 1 area 1

router ospf 1
    redistribute connected
    !redistribute static

R2 — BGP interface is fa0/1

show run | include network
show run | include address

interface FastEthernet0/0
    ip address 10.1.1.1 255.255.255.0
    ip ospf 1 area 1

interface FastEthernet0/1
    no ip address 10.2.2.254 255.255.255.0
    ip address 200.0.0.1 255.255.255.252

router ospf 1
    no network 10.2.2.0 0.0.0.255 area 0
    redistribute connected
    redistribute bgp 65000 subnets
    passive-interface FastEthernet0/1

router bgp 65000
    network 10.1.1.0 mask 255.255.255.0
    network 192.168.122.0
    neighbor 200.0.0.2 remote-as 65002

R3 — BGP interface is fa0/0

show run | include network
show run | include address

interface FastEthernet0/0
    no ip address 10.2.2.1 255.255.255.0
    ip address 200.0.0.2 255.255.255.252

interface FastEthernet0/1
    ip address 10.3.3.254 255.255.255.0
    ip ospf 1 area 2

router ospf 1
    no network 10.2.2.0 0.0.0.255 area 0
    redistribute connected
    redistribute bgp 65002 subnets
    passive-interface FastEthernet0/0

router bgp 65002
    network 10.3.3.0 mask 255.255.255.0
    network 10.4.4.0 mask 255.255.255.0
    neighbor 200.0.0.1 remote-as 65000

R4 — nothing to change here

interface FastEthernet0/0
    ip address 10.3.3.1 255.255.255.0
    ip ospf 1 area 2

interface FastEthernet0/1
    ip address 10.4.4.254 255.255.255.0
    ip ospf 1 area 2

router ospf 1
    redistribute connected

Network acceptance

from R1

show ip route 10.4.4.0

from R4

show ip route 192.168.122.0

from the host system (NAT1)

ping 10.1.1.1

Tips & tricks

One can fake some nodes and advertise routes anyways as such

router bgp 65002
    network 10.0.0.0 mask 255.255.255.0
    network 10.0.1.0 mask 255.255.255.0
    network 10.0.10.0 mask 255.255.255.0
    network 10.0.20.0 mask 255.255.255.0

ip route 10.0.0.0 255.255.0.0 Null0
ip route 10.0.0.0 255.255.255.0 Null0
ip route 10.0.1.0 255.255.255.0 Null0
ip route 10.0.10.0 255.255.255.0 Null0
ip route 10.0.20.0 255.255.255.0 Null0

Resources

https://cisco.goffinet.org/ccna/opsf/configuration-ospfv2-et-ospfv3-cisco-ios/ –> 2.3. Interfaces passives


HOME | GUIDES | LECTURES | LAB | SMTP HEALTH | NU | HTML5
PROXYSELLER — the best individual proxy provider
Copyright © 2021 Pierre-Philipp Braun