BGP with Cisco IOS

bsd/ospf | bsd/ospf-n-bgp | bsd/bgp | cisco/ospf | cisco/ospf-n-bgp | cisco/bgp

assuming gns3 c3725 and c7200 dynamips appliances

IMAGE HERE

vpcs*

ip 10.0.0.1/24 10.0.0.254
ip 10.3.3.1/24 10.3.3.254
save

R1 (c3725)

interface FastEthernet0/0
    ip address 1.2.3.1 255.255.255.0
    no shutdown

interface FastEthernet0/1
    ip address 10.1.1.254 255.255.255.0
    no shutdown

router bgp 65001
    network 1.2.3.0 mask 255.255.255.0
    network 10.1.1.0 mask 255.255.255.0
    neighbor 10.2.3.2 remote-as 65002
    neighbor 1.2.3.2 remote-as 65002
    neighbor 10.2.3.3 remote-as 65003
    neighbor 1.2.3.3 remote-as 65003
    neighbor 10.1.1.1 remote-as 65004

do write memory

R2 (c3725)

    interface FastEthernet0/0
            ip address 1.2.3.2 255.255.255.0
            no shutdown

    interface FastEthernet0/1
            ip address 10.2.2.254 255.255.255.0
            no shutdown

    router bgp 65002
            network 1.2.3.0 mask 255.255.255.0
            network 10.2.2.0 mask 255.255.255.0
            neighbor 10.2.3.1 remote-as 65001
            neighbor 1.2.3.1 remote-as 65001
            neighbor 10.2.3.3 remote-as 65003
            neighbor 1.2.3.3 remote-as 65003
            neighbor 10.2.2.1 remote-as 65005

    do write memory

R3 (c7200) — announcing default route and SNAT

    interface FastEthernet0/0
            ip address 1.2.3.3 255.255.255.0
    ip nat inside
            no shutdown

    interface FastEthernet0/1
            ip address dhcp
    ip nat outside
            no shutdown

    ip nat inside source list 1 interface fa0/1 overload
    ip nat inside source list 2 interface fa0/1 overload
    ip nat inside source list 3 interface fa0/1 overload
    ip nat inside source list 4 interface fa0/1 overload
    ip nat inside source list 5 interface fa0/1 overload

    access-list 1 permit 10.0.0.0 0.0.0.255
    access-list 2 permit 10.1.1.0 0.0.0.255
    access-list 3 permit 10.2.2.0 0.0.0.255
    access-list 4 permit 10.3.3.0 0.0.0.255
    access-list 5 permit 1.2.3.0 0.0.0.255

    router bgp 65003
    network 0.0.0.0
            network 1.2.3.0 mask 255.255.255.0
            network 192.168.122.0
            neighbor 1.2.3.1 remote-as 65001
            neighbor 1.2.3.2 remote-as 65002

    do write memory
do show interfaces fa0/1

R4 (c3725)

    interface FastEthernet0/0
            ip address 10.1.1.1 255.255.255.0
            no shutdown

    interface FastEthernet0/1
            ip address 10.0.0.254 255.255.255.0
            no shutdown

    router bgp 65004
            network 10.1.1.0 mask 255.255.255.0
            network 10.0.0.0 mask 255.255.255.0
            neighbor 10.1.1.254 remote-as 65001

    do write memory

R5 (c3725)

    interface FastEthernet0/0
            ip address 10.2.2.1 255.255.255.0
            no shutdown

    interface FastEthernet0/1
            ip address 10.3.3.254 255.255.255.0
            no shutdown

    router bgp 65005
            network 10.2.2.0 mask 255.255.255.0
            network 10.3.3.0 mask 255.255.255.0
            neighbor 10.2.2.254 remote-as 65002

    do write memory

R*

do show ip bgp
do show ip route

vpcs1

ping 10.3.3.1
trace 10.3.3.1

ping 192.168.122.1
trace 192.168.122.1

ping 1.1.1.1
trace 1.1.1.1

Troubleshooting

"C3725 'Ghost': generic_nvram_extract_config: Unknown error -61605"

==> install the i386 flavor of dynamips

Error : Activation failed due to insufficient dynamic memory

==> increase RAM to 256 MiB

Resources

Difference between Default-originate and network 0.0.0.0 in BGP https://community.cisco.com/t5/routing/difference-between-default-originate-and-network-0-0-0-0-in-bgp/td-p/1780201

BGP Configuration for a Transit ISP https://ftp.registro.br/pub/gter/gter30/TutorialBGP/7%20-%20Transit.pdf

BGP Prevent Transit AS https://networklessons.com/bgp/bgp-prevent-transit-as

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_bgp/command/irg-cr-book/bgp-n1.html

https://www.cisco.com/c/en/us/support/docs/ip/open-shortest-path-first-ospf/113339-ospf-connected-net.html

https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist.html

https://community.cisco.com/t5/routing/does-bgp-advertise-connected-routes-by-default/td-p/1270608

nat

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_nat/configuration/xe-16/nat-xe-16-book/iadnat-addr-consv.html

https://www.networkstraining.com/configuring-nat-on-cisco-routers/

https://www.practicalnetworking.net/stand-alone/cisco-nat-configurations-ios-router/

https://networklessons.com/cisco/ccie-routing-switching/cisco-ios-nat-stick-configuration-example


HOME | GUIDES | LECTURES | LAB | SMTP HEALTH | HTML5 | CONTACT
Copyright © 2024 Pierre-Philipp Braun