cisco ios // casual setup

basics | defaults | fw | init | lacp | passwords | setup | ssh

defaults

see defaults

initial setup

what the wizard does:

w/o the wizard

    conf t

define a hostname and bring the interfaces up on vlan1

    hostname SWITCH-NAME/MODEL
    !ip domain-name localdomain

    interface vlan1
            no shutdown
            ip address 10.7.7.203 255.255.255.0
            ip route-cache

default vlan

the management ip can also be set on an alternate VLAN (vlan1 by default) – but only one Switch Virtual Interface at a time (at least for those old layer 2 switches like the 2950)

and check

show vlan name mgmt
vlan database
show

casual port setup

access mode

interface fa0/0
            switchport access vlan 2
            switchport mode access
            spanning-tree portfast
            end

and check

    show vlan id 2

trunk mode

defining an access vlan right in front of the trunk helps to fallback there in case of troubles

    interface fa0/0
            switchport access vlan XXX
            switchport trunk encapsulation dot1q
            switchport mode trunk

and check

    show interface fa0/0
    show interface fa0/0 trunk

tuning required

eventually disable snmp

!no snmp-server

disable the freaking WUI – in case you really wanna try it out, reach port 80 and enter password w/o username

no ip http server
no ip http secure-server

and check

end
show running-config

ready to go

    show running-config
    write memory
    !copy running-config startup-config

and eventually make sure everything goes smooth after a restart

    reload

resources

vlan

vlan internal allocation policy ascending https://community.cisco.com/t5/routing/vlan-internal-allocation-policy-ascending/td-p/696546

Internal Vlan usage for routed port https://community.cisco.com/t5/routing/internal-vlan-usage-for-routed-port/td-p/1724721

Wireshark capture VLAN IDs https://community.cisco.com/t5/network-management/wireshark-capture-vlan-ids/td-p/3178402

How To Configure VLANs On the Catalyst Switches https://community.cisco.com/t5/networking-documents/how-to-configure-vlans-on-the-catalyst-switches/ta-p/3131780

Delete a configuration of an interface https://community.cisco.com/t5/switching/delete-a-configuration-of-an-interface/td-p/1495108 https://community.cisco.com/t5/switching/is-there-a-way-to-quickly-remove-config-from-a-range-of-ports/td-p/2024486 https://community.cisco.com/t5/switching/clear-config-interface/td-p/1478260 https://community.cisco.com/t5/switching/clear-the-config-off-an-interface/td-p/1042596

VLAN analysis With Wireshark https://www.youtube.com/watch?v=CSUuEnYEwMQ

VLAN range 1006-1024 https://learningnetwork.cisco.com/thread/118672

Creating a VLAN for Cisco Networking https://www.dummies.com/programming/networking/creating-a-vlan-for-cisco-networking/

save config

https://community.cisco.com/t5/other-network-architecture/howto-save-running-config-file-from-cli/td-p/362191

https://www.dummies.com/programming/networking/cisco/cisco-networking-configuration-saving/

https://serverfault.com/questions/559082/how-do-you-save-the-configuration-of-a-cisco-switch


HOME | GUIDES | LECTURES | LAB | SMTP HEALTH | HTML5 | CONTACT
Copyright © 2024 Pierre-Philipp Braun