Cisco IOS // Setup VLAN

assuming gns3 appliance

tested on c3725 + NM-15ESW

IMAGE HERE

Introduction

we are isolating two virtual LANs

buster1,2 (vlan20) at the top
buster3,4 (vlan10) at the bottom

Requirements

assuming c3725 + 16 port switch module

we need to add memory

Right-click > Configure

pcmcia disk0: 32M
pcmcia disk1: 32M

we also need to make it happen as such

all switchen

format flash:

confirm
confirm

Setup

switch 1 & 2

vlan 20
name ef
state active

vlan 10
name best-effort
state active

interface fa1/2
switchport access vlan 20
!switchport mode access
spanning-tree portfast

interface fa1/1
switchport access vlan 10
!switchport mode access
spanning-tree portfast

interface fa1/6
!switchport trunk encapsulation dot1q
!switchport trunk allowed vlan all
!switchport trunk native vlan 1
switchport mode trunk
end
show vlan-switch
show interfaces fa1/6 trunk
show run
write mem

buster1,2,3,4

assign an IP on the same subnet for all buster systems e.g. buster1

allow-hotplug eth0
iface eth0 inet static
    address 10.1.1.1/24

Acceptance

from buster1 (vlan20)

ping 10.1.1.2 # OK
ping 10.1.1.3 # DOES NOT RESPOND
ping 10.1.1.4 # DOES NOT RESPOND

from buster3 (vlan10)

ping 10.1.1.1 # DOES NOT RESPOND
ping 10.1.1.2 # DOES NOT RESPOND
ping 10.1.1.4 # OK

Resources

hw req

Cisco EtherSwitch Modules for the Integrated Services Routers Routers https://www.vtkt.ru/upload/iblock/61e/Cisco_NM-ESW.pdf

NM-16ESW & NM-32ESW with DLSw https://www.cisco.com/c/en/us/support/docs/ibm-technologies/data-link-switching-dlsw-data-link-switching-plus-dlsw-/26888-nm-esw.html

making NM-16ESW in 2611XM work ? https://community.cisco.com/t5/other-network-architecture/making-nm-16esw-in-2611xm-work/td-p/256323

Why can’t create vlan in GNS 3 https://gns3.com/community/featured/why-can-t-create-vlan-in-gns-3

not enough space on flash while creating VLANs https://gns3.com/community/featured/not-enough-space-on-flash-while-

GNS3 - not enough space on flash to store vlan database https://www.analysisman.com/2020/11/gns3-vlan.html

vlan

[FR] COMMANDES COMMUTATEURS CISCO https://www.numelion.com/commandes-commutateurs-cisco.html

VLANs (Virtual LANs) - IOS https://netref.soe.ucsc.edu/node/40

trunk

Trunking on Cisco IOS Switch https://networklessons.com/switching/how-to-configure-trunk-on-cisco-catalyst-switch

Encapsulation Dot1Q Command on CISCO Router/Switch https://itexamanswers.net/encapsulation-dot1q-command-on-cisco-router-switch.html

Configuring Trunking https://www.cisco.com/en/US/docs/storage/san_switches/mds9000/sw/rel_2_x/san-os/configuration/guide/trnk.pdf

Configuring VLAN Trunks https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/vlan/configuration_guide/b_vlan_152ex_2960-x_cg/b_vlan_152ex_2960-x_cg_chapter_0100.pdf

Configuring VLAN Trunks https://www.cisco.com/en/US/docs/switches/lan/catalyst3850/software/release/3.2_0_se/multibook/configuration_guide/b_consolidated_config_guide_3850_chapter_0100010.html

Configuring Trunk Ports (switch Cisco) https://howto-madkour.blogspot.com/2013/03/configuring-trunk-ports-switch-cisco.html

troubles

basic vlan http://forum.gns3.net/topic5264.html

EtherSwitch Network Module (ESW) Configuration Example https://www.cisco.com/c/en/us/support/docs/interfaces-modules/network-modules/82156-ether-switch-nm-config.html

Some interfaces/VLAn are not trunking https://community.cisco.com/t5/switching/some-interfaces-vlan-are-not-trunking/td-p/2318988

vlan stp

STP forwarding and pruning problem https://community.cisco.com/t5/switching/stp-forwarding-and-pruning-problem/td-p/897549 –> show spanning-tree vlan n

Cannot get VLAN in spanning tree forwarding state https://community.cisco.com/t5/switching/cannot-get-vlan-in-spanning-tree-forwarding-state/td-p/2136885

HOW TO CONFIGURE ROUTER ON A STICK - 802.1Q TRUNK TO CISCO ROUTER https://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/336-cisco-router-8021q-router-stick.html –> spanning-tree portfast trunk


HOME | GUIDES | LECTURES | LAB | SMTP HEALTH | HTML5 | CONTACT
Copyright © 2024 Pierre-Philipp Braun