playing with cisco ios

draft – tested on old Catalysts 2950

understanding the defaults

subnet-zero

ip subnet-zero

historically allows first .0 and last subnets .255

pvst

spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id

keepalive loop

you will notice LOOP packets in wireshark, as keepalive is the default. keep it as such

Consquences of “no keepalive” on switch port https://learningnetwork.cisco.com/thread/35077

Error - “%ETHCNTR-3-LOOP_BACK_DETECTED” Catalyst switch that runs Cisco IOSĀ® Software https://community.cisco.com/t5/networking-documents/error-quot-ethcntr-3-loop-back-detected-quot-catalyst-switch/ta-p/3127989

Disabling keepalive in switch https://community.cisco.com/t5/switching/disabling-keepalive-in-switch/td-p/2275311

access

interface fa0/X
switchport access vlan XXX
switchport mode access
spanning-tree portfast
exit

eventually find out what NIC is connected to that port

trunk & vtp

pass the VTP adverts through to trunks only,

vtp mode transparent

more about discovery protocols

interface gi0/X
switchport access vlan XXX
switchport mode trunk
exit
do show interface gi0/1 trunk

defining an access vlan right in front of the trunk helps to fallback there in case of troubles

ready to go

do write memory
!do copy running-config startup-config

resources

basics

https://en.wikipedia.org/wiki/Cisco_IOS

Introduction to Cisco IOS CLI (Command-Line Interface) https://networklessons.com/cisco/ccna-routing-switching-icnd1-100-105/introduction-cisco-ios-cli-command-line-interface

User Mode and Privileged Mode Security https://networklessons.com/cisco/ccna-routing-switching-icnd1-100-105/user-mode-and-privileged-mode-security

IOS and Configuration Basics https://www.cisco.com/c/en/us/td/docs/switches/wan/mgx/mgx_8850/software/mgx_r3/rpm/rpm_r1-1/configuration/guide/appc.html https://learningnetwork.cisco.com/welcome

Cisco IOS Configuration Fundamentals Command Reference https://www.cisco.com/c/en/us/td/docs/ios/fundamentals/command/reference/cf_book/cf_s4.html

Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 https://www.cisco.com/c/en/us/td/docs/ios/12_2/configfun/command/reference/ffun_r/frfusing.html

IOS and Configuration Basics https://www.cisco.com/c/en/us/td/docs/switches/wan/mgx/mgx_8850/software/mgx_r3/rpm/rpm_r1-1/configuration/guide/appc.html

howto save Running Config File from CLI ? https://community.cisco.com/t5/other-network-architecture/howto-save-running-config-file-from-cli/td-p/362191 https://www.dummies.com/programming/networking/cisco/cisco-networking-configuration-saving/ https://serverfault.com/questions/559082/how-do-you-save-the-configuration-of-a-cisco-switch

Cisco Courses https://networklessons.com/cisco

Self-Paced Lessons https://learningnetwork.cisco.com/community/learning_center/expert-level-training/ccie-routing-switching/self-paced-lessons

understanding

What is IP Subnet Zero? - Cisco Articles & Tips https://www.petri.com/csc_ip_subnet_zero

What does ip subnet-zero command do? https://learningnetwork.cisco.com/thread/32136

vlan

vlan internal allocation policy ascending https://community.cisco.com/t5/routing/vlan-internal-allocation-policy-ascending/td-p/696546

Internal Vlan usage for routed port https://community.cisco.com/t5/routing/internal-vlan-usage-for-routed-port/td-p/1724721

Catalyst 3560 Software Configuration Guide, Release 12.2(58)SE https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3560/software/release/12-2_58_se/configuration/guide/3560scg/swvlan.html

VLAN analysis With Wireshark https://www.youtube.com/watch?v=CSUuEnYEwMQ

Wireshark capture VLAN IDs https://community.cisco.com/t5/network-management/wireshark-capture-vlan-ids/td-p/3178402

VLAN range 1006-1024 https://learningnetwork.cisco.com/thread/118672


Nethence | Pub | Lab | Pbraun | SNE Russia | xhtml